欢迎光临
我们一直在努力

AMP – 一款适用于Linux终端的Vi / Vim灵感文本编辑器

Amp是一款轻量级,功能齐全的Vi / Vim灵感文本编辑器,用于Linux终端,用Rust编写。 它以简化的方式提供了Vi / Vim的核心交互模型,并汇集了现代文本编辑器所需的基本功能。

它是一个零配置,无插件和基于终端的用户界面,与终端仿真器(如tmuxAlacritty)结合得非常好。 Amp还支持受Vim启发的模式化键盘驱动界面,可快速导航和编辑文本。

AMP特点:

  • 文件查找器 – 使用简单,精确的匹配算法快速索引和搜索文件,默认情况下忽略git文件夹。
  • 轻松移动 – 快速光标移动,无需重复击键。
  • 符号跳转 – 转到当前缓冲区中的任何类,窗体或方法定义。
  • 灵活的键盘映射 – 易于使用的基于YAML的键映射,能够将多个内置命令创建为新的自定义宏。

要求

  1. 系统上必须安装Rust编程语言
  2. 这些依赖关系libxcb,openssl,zlib,cmake和python3包必须安装在系统上。

如何在Linux中安装Amp文本编辑器

要从源代码安装AMP文本编辑器 ,必须首先使用以下命令在各自的Linux发行版上安装指定的依赖项。

$ sudo apt-get git libxcb1-dev libssl-dev zlib1g-dev cmake python3   [On Debian/Ubuntu]# yum install git libxcb openssl-devel zlib-devel cmake python3      [On CentOS/RHEL]# dnf install git libxcb openssl-devel zlib-devel cmake python3      [On Fedora]

一旦安装了所有必需的依赖项,您现在可以从其github存储库中克隆AMP源代码,并使用以下命令进行安装。

$ git clone https://github.com/jmacdonald/amp.git$ cd amp$ ls$ cargo install amp

Arch Linux上 ,您可以如图所示从AUR存储库安装AMP

$ git clone https://aur.archlinux.org/amp.git$ cd amp$ makepkg -isr

如何在Linux中使用Amp文本编辑器

在开始使用Amp之前,学习如何退出总是一个好习惯。 在正常模式下键入Q(Shift+q)退出AMP

现在您可以使用AMP文本编辑器打开或创建新文件,如图所示。

$ amp howtoing.txt

使用放大器打开文件后,按i插入文本,然后按Esc键,然后按s将更改保存到文件。

AMP在开放模式下

AMP在开放模式下

正常模式下的AMP

正常模式下的AMP

AMP保持打开模式

AMP保持打开模式

有关更多信息和用法以及配置选项,请参阅放大器文档

Amp仍处于早期阶段,某些功能尚未添加。 不过,它适用于日常使用,但有一些例外情况。 试试看,并通过下面的评论部分分享你的想法。

赞(0) 打赏
未经允许不得转载:老赵部落 » AMP – 一款适用于Linux终端的Vi / Vim灵感文本编辑器

评论 抢沙发