欢迎光临
我们一直在努力

Ubuntu升级Git使用最新版本

问题:Ubuntu无法升级到Git最新版本

我正在运行的脚本,从GitHub克隆一些git档案,而我看到了以下错误:

Please upgrade your git client.GitHub.com no longer supports git over dumb-http: https://github.com/blog/809-git-dumb-http-transport-to-be-turned-off-in-90-days

但是,当我试图升级git时,Ubuntu告诉我,我已经是最新版本:

$ sudo apt-get install gitReading package lists... DoneBuilding dependency treeReading state information... Donegit is already the newest version.0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

但我实际上没有最新版本。

解决方法:在Ubuntu系统中添加Git软件源(git 维护团队)

要获得最新版本的Git,你需要在Ubuntu中添加Git的维护者团队PPA(归档包)到您的软件源列表。使用以下命令添加PPA:

$ sudo add-apt-repository ppa:git-core/ppa

然后更新源列表并升级git:

$ sudo apt-get update$ sudo apt-get install -y git

现在,你应该已经是最新版本,使用以下命令查看git版本:

git --version

赞(0) 打赏
未经允许不得转载:老赵部落 » Ubuntu升级Git使用最新版本

评论 抢沙发